Instalasi, Konfigurasi dan Optimasi MikrotikRouter

April 13, 2008 at 6:53 am Tinggalkan komentar

MikroTik RouterOS™, merupakan system operasi Linux base yang diperuntuk kan sebagai network router. Didesain untuk memberikan kemudahan bagi penggunanya. Administrasinya bisa dilakukan melalui Windows application (WinBox). Webbrowser serta via Remote Shell (telnet dan SSH). Selain itu instalasi dapat dilakukan pada Standard computer PC. PC yang akan dijadi kan router mikrotikpun tidak memerlukan resource yang cukup besar untuk penggunaan standard, misalnya hanya sebagai gateway. Untuk keperluan
beban yang besar ( network yang kompleks, routing yang rumit dll)disarankan untuk mempertimbangkan pemilihan resource PC yang memadai.

Fasilitas pada mikrotik antara lain sebagai berikut :
– Protokoll routing RIP, OSPF, BGP.
– Statefull firewall
– HotSpot for Plug-and-Play access
– remote winbox GUI admin

Lebih lengkap bisa dilihat di http://www.mikrotik.com/

Meskipun demikian Mikrotik bukanlah free software, artinya kita harus membeli licensi terhadap segala fasiltas yang disediakan. Free trial hanya untuk 24 jam saja. Kita bisa membeli software mikrotik dalam bentuk CD yang diinstall pada Hard disk atau disk on module (DOM). Jika kita membeli DOM tidak perlu install tetapi tinggal menancapkan DOM pada slot IDE PC kita.

Instalasi Mikrotik ada beberapa cara :
1. Instalasi melalui NetInstall via jaringan
2. Instalasi melalui Floppy disk
3. Instalasi melalui CD-ROM.

Langkah-langkah berikut adalah dasar-dasar setup mikrotik yang dikonfigurasikan untuk jaringan sederhana sebagai PC Router/Gateway, Web Proxy, DNS Server, DHCP, Firewall serta Bandwidth Management. Konfigurasi ini dapat dimanfaatkan untuk membangun jaringan pada Internet Cafe atau untuk Testing pada Laboratorium Pribadi.

Topologi Jaringan

Topologi jaringan ini di anggap koneksi Internetnya melalui MODEM xDSL (ADSL atau SDSL). Dengan catatan konfigurasi IP Publiknya ditanam didalam MODEM, artinya perlu pula dipilih MODEM yang memiliki fasilitas seperti Routing, Firewall, dan lain-lain. Semakin lengkap semakin bagus, namun biasanya harga semakin mahal, yang patut dipertimbangkan pilihlah MODEM yang memiliki fasilitas Firewall yang bagus.

Untuk MODEM SDSL, biasanya, IP dibawah NAT, artinya IP nya bukan IP Publik langsung. Dan umumnya untuk MODEM ADSL, IP Publiknya langsung ditanam di MODEM itu sendiri.

Saat ini kita anggap IP Publiknya di tanam di MODEM, dimana Interface PPPoE nya sudah di konfigurasikan dan sudah bisa DIAL ke server RASnya.

Agar memudahkan konfigurasi, perlu dirancang topologi jaringan yang dikonfigurasi. Sebagai contoh, skema dibawah ini:

(a) Skema Jaringan
(1) = Modem xDSL (Ip Address : 192.168.1.1/24)
(2) = Mikrotik Box dengan 2 ethernet card yaitu a (publik) dan b (local)
(3) = Switch
Untuk sambungan ke Client. Asumsi Client Jumlahnya 20 Client
Range Ip Address : 192.168.0.0/27
Alokasi Ip Client = 192.168.0.1-192.168.0.30
Ip Net ID : 192.168.0.0/27
Ip Broadcast : 192.168.0.31/27

(b) Alokasi IP Address

[*] Mikrotik Box

Keterangan Skema
a = ethernet card 1 (Publik) -> Ip Address : 192.168.1.2/24
b = ethernet card 2 (Local) -> Ip Address : 192.168.0.30/27

Gateway : 192.168.1.1 (ke Modem)

[*] Client
Client 1 – Client n, Ip Address : 192.168.0.n …. n (1-30)

Contoh:
Client 6
Ip Address : 192.168.0.6/27
Gateway : 192.168.0.30 (ke Mikrotik Box)

CATATAN :
Angka dibelakang Ip address ( /27) sama dengan nilai netmasknya
untuk angka (/27) nilainya sama dengan 255.255.255.224.

Untuk Sub Netmask blok ip address Local kelas C, dapat diuraikan
sebagai berikut :

Subnetmask kelas C
——————-
255.255.255.0 = 24 -> 254 mesin
.. .128 = 25 -> 128 mesin
.. .192 = 26 -> 64 mesin
.. .224 = 27 -> 32 mesin
.. .240 = 28 -> 16 mesin
.. .248 = 29 -> 8 mesin
.. .252 = 30 -> 4 mesin
.. .254 = 31 -> 2 mesin
.. .255 = 32 -> 1 mesin

Persiapan
– Untuk PC Router Siapkan PC, minimal Pentium I, RAM 64, HD 500M atau pake flash memory 64 – Sebagai Web proxy, Siapkan PC, minimal Pentium III 450Mhz, RAM 256 Mb, HD 20 Gb.
– Siapkan minimal 2 ethernet card, 1 ke arah luar/Internet dan 1 lagi ke Network local
– Burn Source CD Mikrotik OS masukan ke CDROM.
– Versi mikrotik yang digunakan adalah Mikrotik RouterOS versi 2.9.27

next..

Perintah Dasar

Perintah mikrotik sebenarnya hampir sama dengan perintah yang ada dilinux, sebab pada dasarnya mikrotik ini merupakan kernel Linux, hasil pengolahan kembali Linux dari Distribusi Debian. Pemakaian perintah shellnya sama, seperti penghematan perintah, cukup menggunakan tombol TAB di keyboard maka perintah yang panjang, tidak perlu lagi diketikkan, hanya ketikkan awal nama perintahnya, nanti secara otomatis Shell akan menampilkan sendiri perintah yang berkenaan. Misalnya perintah IP ADDRESS di mikrotik. Cukup hanya mengetikkan IP ADD spasi tekan tombol TAB, maka otomatis shell akan mengenali dan menterjemahkan sebagai perintah IP ADDRESS.

Baiklah kita lanjutkan pengenalan perintah ini.

Setelah login, cek kondisi interface atau ethernet card.

Melihat kondisi interface pada Mikrotik Router

QUOTE:

[admin@Mikrotik] > interface print
Flags: X – disabled, D – dynamic, R – running
# NAME TYPE RX-RATE TX-RATE MTU
0 R ether1 ether 0 0 1500
1 R ether2 ether 0 0 1500

[admin@Mikrotik]>

Jika interfacenya ada tanda X (disabled) setelah nomor (0,1), maka periksa lagi
etherned cardnya, seharusnya R (running).

a. Mengganti nama interface

Code:

[admin@Mikrotik] > interface(enter)

b. Untuk mengganti nama Interface ether1 menjadi Public (atau terserah namanya), maka

Code:

[admin@Mikrotik] interface> set 0 name=Public

c. Begitu juga untuk ether2, misalkan namanya diganti menjadi Local, maka

Code:

[admin@Mikrotik] interface> set 1 name=Local

d. atau langsung saja dari posisi root direktori, memakai tanda “/”, tanpa tanda kutip

Code:

[admin@Mikrotik] > /interface set 0 name=Public

e. Cek lagi apakah nama interface sudah diganti.

Oke Next..

Setting IP Address, Gateway, Masqureade dan Name Server
IP Address

Bentuk Perintah konfigurasi

ip address add address ={ip address/netmask} interface={nama interface}

a. Memberikan IP address pada interface Mikrotik. Misalkan Public akan kita gunakan untuk koneksi ke Internet dengan IP 192.168.1.2 dan Local akan kita gunakan untuk network LAN kita dengan IP 192.168.0.30 (Lihat topologi)

Code:


[admin@routerku] > ip address add address=192.168.1.2 netmask=255.255.255.0 interface=Public comment=IP ke Internet


Code:


[admin@routerku] > ip address add address=192.168.0.30 netmask=255.255.255.224 interface=Local comment =IP ke LAN


b. Melihat konfigurasi IP address yang sudah kita berikan

Code:


[admin@routerku] >ip address print


Gateway Bentuk Perintah Konfigurasi ip route add gateway={ip gateway} a. Memberikan default Gateway, diasumsikan gateway untuk koneksi internet adalah 192.168.1.1

Code:


[admin@routerku] > / ip route add gateway=192.168.1.1


b. Melihat Tabel routing pada Mikrotik Routers

Code:


[admin@routerku] > ip route print


c. Tes Ping ke Gateway untuk memastikan konfigurasi sudah benar

Code:


[admin@routerku] > ping 192.168.1.1


NAT (Network Address Translation) Bentuk Perintah Konfigurasi ip firewall nat add chain=srcnat action=masquerade out-inteface={ethernet yang langsung terhubung ke Internet atau Public} a. Setup Masquerading, Jika Mikrotik akan kita pergunakan sebagai gateway server maka agar client computer pada network dapat terkoneksi ke internet perlu kita masquerading.

Code:


[admin@routerku] > ip firewall nat add chain=scrnat out-interface=Public action=masquerade


b. Melihat konfigurasi Masquerading

Code:


[admin@routerku] ip firewall nat print


Name server Bentuk Perintah Konfigurasi ip dns set primary-dns={dns utama} secondary-dns={dns ke dua} a. Setup DNS pada Mikrotik Routers, misalkan DNS dengan Ip Addressnya Primary = 202.134.0.155, Secondary = 202.134.2.5

Code:


[admin@routerku] > ip dns set primary-dns=202.134.0.155 allow-remoterequests=no


Code:


[admin@routerku] > ip dns set secondary-dns=202.134.2.5 allow-remoterequests=no


b. Melihat konfigurasi DNS

Code:


[admin@routerku] > ip dns print


c. Tes untuk akses domain, misalnya dengan ping nama domain

Code:


[admin@routerku] > ping yahoo.com


Jika sudah berhasil reply berarti seting DNS sudah benar. Setelah langkah ini bisa dilakukan pemeriksaan untuk koneksi dari jaringan local. Dan jika berhasil berarti kita sudah berhasil melakukan instalasi Mikrotik Router sebagai Gateway server. Setelah terkoneksi dengan jaringan Mikrotik dapat dimanage menggunakan WinBox yang bisa di download dari Mikrotik.com atau dari server mikrotik kita. Misal Ip address server mikrotik kita 192.168.0.30, via browser buka http://192.168.0.30. Di Browser akan ditampilkan dalam bentuk web dengan beberapa menu, cari tulisan Download dan download WinBox dari situ. Simpan di local harddisk. Jalankan Winbox, masukkan Ip address, username dan password.

Next…

Transparent Proxy Server

Proxy server merupakan program yang dapat mempercepat akses ke suatu web yang sudah diakses oleh komputer lain, karena sudah di simpan didalam caching server.Transparent proxy menguntungkan dalam management client, karena system administrator tidak perlu lagi melakukan setup proxy di setiap browser komputer client karena redirection dilakukan otomatis di sisi server.

Bentuk perintah konfigurasi :
a. Setting web proxy :

– ip proxy set enable=yes
port={ port yang mau digunakan }
maximal-client-connections=1000
maximal-server-connections=1000

– ip proxy direct add src-address={ network yang akan di NAT} action=allow

– ip web-proxy set parent-proxy={proxy parent/optional}
hostname={ nama host untuk proxy/optional}
port={port yang mau digunakan}
src-address={ address yang akan digunakan untuk koneksi
ke parent proxy/default 0.0.0.0}
transparent-proxy=yes
max-object-size={ ukuran maximal file yang akan disimpan
sebagai cache/default 4096 in Kilobytes}
max-cache-size= { ukuran maximal hardisk yang akan dipakai sebagai penyimpan file cache/unlimited | none | 12 in megabytes}
cache-administrator={ email administrator yang akan digunakan apabila proxy error, status akan dikirim ke email tersebut}
enable==yes

a. Web proxy setting

Perintah :
/ ip web-proxy set enabled=yes src-address=0.0.0.0 port=8080
hostname=proxy.routerku.co.id transparent-proxy=yes
parent-proxy=0.0.0.0:0 cache-administrator= support@routerku.co.id This e-mail address is being protected from spam bots, you need JavaScript enabled to view it
max-object-size=131072KiB cache-drive=system max-cache-size=unlimited
max-ram-cache-size=unlimited

Nat Redirect, perlu ditambahkan yaitu rule REDIRECTING untuk membelokkan
traffic HTTP menuju ke WEB-PROXY.

b. Setting firewall untuk Transparant Proxy

Bentuk perintah konfigurasi :

ip firewall nat add chain=dstnat
protocol=tcp
dst-port=80
action=redirect
to-ports={ port proxy }

Perintahnya:

/ ip firewall nat
add chain=dstnat protocol=tcp dst-port=80 action=redirect to-ports=8080 disabled=no
add chain=dstnat protocol=tcp dst-port=3128 action=redirect to-ports=8080 disabled=no
add chain=dstnat protocol=tcp dst-port=8000 action=redirect to-ports=8080

perintah diatas dimaksudkan, agar semua trafik yang menuju Port 80,3128,8000 dibelokkan menuju port 8080 yaitu portnya Web-Proxy.

CATATAN:
Perintah

/ip web-proxy print { untuk melihat hasil konfigurasi web-proxy}
/ip web-proxy monitor { untuk monitoring kerja web-proxy}

Bandwidth Management

QoS memegang peranan sangat penting dalam hal memberikan pelayanan yang baik pada client. Untuk itu kita memerlukan bandwidth management untuk mengatur tiap data yang lewat, sehingga pembagian bandwidth menjadi adil. Dalam hal ini Mikrotik RouterOs juga menyertakan packet software untuk memanagement bandwidth.

Bentuk perintah konfigurasi:

queue simple add name={ nama }
target-addresses={ ip address yang dituju }
interface={ interface yang digunakan untuk melewati data }
max-limit={ out/in }

Dibawah ini terdapat konfigurasi Trafik shaping atau bandwidth management dengan metode Simple Queue, sesuai namanya, Jenis Queue ini memang sederhana, namun memiliki kelemahan, kadangkala terjadi kebocoran bandwidth atau bandwidthnya tidak secara real di monitor. Pemakaian untuk 10 Client, Queue jenis ini tidak masalah.

Diasumsikan Client ada sebanyak 15 client, dan masing-masing client diberi jatah bandwidth minimum sebanyak 8kbps, dan maksimum 48kbps. Sedangkan Bandwidth totalnya sebanyak 192kbps. Untuk upstream tidak diberi rule, berarti masing-masing client dapat menggunakan bandwidth uptream secara maksimum. Perhatikan perintah priority, range priority di Mikrotik sebanyak delapan. Berarti dari 1 sampai 8, priority 1 adalah priority tertinggi, sedangkan priority 8 merupakan priority terendah.

Next..

—> Sambungan Bandwidth Management
Diasumsikan Client ada sebanyak 15 client, dan masing-masing client diberi jatah bandwidth minimum sebanyak 8kbps, dan maksimum 48kbps. Sedangkan Bandwidth totalnya sebanyak 192kbps. Untuk upstream tidak diberi rule, berarti masing-masing client dapat menggunakan bandwidth uptream secara maksimum. Perhatikan perintah priority, range priority di Mikrotik sebanyak delapan. Berarti dari 1 sampai 8, priority 1 adalah priority tertinggi, sedangkan priority 8 merupakan priority terendah.

Berikut Contoh kongirufasinya.

Code:


/ queue simple


Code:


add name=01 target-addresses=192.168.0.1/32 dst-address=0.0.0.0/0 interface=all priority=1 queue=default/default limit-at=0/8000 max-limit=0/48000 total-queue=default disabled=no


Code:


add name=02 target-addresses=192.168.0.2/32 dst-address=0.0.0.0/0 interface=all priority=1 queue=default/default limit-at=0/8000 max-limit=0/48000 total-queue=default disabled=no


Code:


add name=03 target-addresses=192.168.0.3/32 dst-address=0.0.0.0/0 interface=all priority=1 queue=default/default limit-at=0/8000 max-limit=0/48000 total-queue=default disabled=no


Code:


add name=04 target-addresses=192.168.0.4/32 dst-address=0.0.0.0/0 interface=all priority=1 queue=default/default limit-at=0/8000 max-limit=0/48000 total-queue=default disabled=no


Code:


add name=05 target-addresses=192.168.0.5/32 dst-address=0.0.0.0/0 interface=all priority=1 queue=default/default limit-at=0/8000 max-limit=0/48000 total-queue=default disabled=no


Code:


add name=06 target-addresses=192.168.0.6/32 dst-address=0.0.0.0/0 interface=all priority=1 queue=default/default limit-at=0/8000 max-limit=0/48000 total-queue=default disabled=no


Code:


add name=07 target-addresses=192.168.0.7/32 dst-address=0.0.0.0/0 interface=all priority=1 queue=default/default limit-at=0/8000 max-limit=0/48000 total-queue=default disabled=no


Code:


add name=08 target-addresses=192.168.0.8/32 dst-address=0.0.0.0/0 interface=all priority=1 queue=default/default limit-at=0/8000 max-limit=0/48000 total-queue=default disabled=no


Code:


add name=09 target-addresses=192.168.0.9/32 dst-address=0.0.0.0/0 interface=all priority=1 queue=default/default limit-at=0/8000 max-limit=0/48000 total-queue=default disabled=no


Code:


add name=10 target-addresses=192.168.0.10/32 dst-address=0.0.0.0/0 interface=all priority=1 queue=default/default limit-at=0/8000 max-limit=0/48000 total-queue=default disabled=no


Code:


add name=11 target-addresses=192.168.0.11/32 dst-address=0.0.0.0/0 interface=all priority=1 queue=default/default limit-at=0/8000 max-limit=0/48000 total-queue=default disabled=no


Code:


add name=12 target-addresses=192.168.0.12/32 dst-address=0.0.0.0/0 interface=all priority=1 queue=default/default limit-at=0/8000 max-limit=0/48000 total-queue=default disabled=no


Code:


add name=13 target-addresses=192.168.0.13/32 dst-address=0.0.0.0/0 interface=all priority=1 queue=default/default limit-at=0/8000 max-limit=0/48000 total-queue=default disabled=no


Code:


add name=14 target-addresses=192.168.0.14/32 dst-address=0.0.0.0/0 interface=all priority=1 queue=default/default limit-at=0/8000 max-limit=0/48000 total-queue=default disabled=no


Code:


add name=15 target-addresses=192.168.0.15/32 dst-address=0.0.0.0/0 interface=all priority=1 queue=default/default limit-at=0/8000 max-limit=0/48000 total-queue=default disabled=no


Perintah diatas karena dalam bentuk command line, bisa juga di copy paste, selanjutnya di paste saja ke consol mikrotiknya. Ingat lihat dulu path atau direktory aktif. Silahkan dipaste saja, kalau posisi direktorynya di Root. Pilihan lain metode bandwidth manajemen ini, kalau seandainya ingin bandwidth tersebut dibagi sama rata oleh Mikrotik, seperti bandwidth 256kbps downstream dan 256kbps upstream. Sedangkan client yang akan mengakses sebanyak 10 client, maka otomatis masing-masing client mendapat jatah bandwidth upstream dan downstream sebanyak 256kbps dibagi 10. Jadi masing-masing dapat 25,6kbps. Andaikata hanya 2 Client yang mengakses maka masing-masing dapat 128kbps. Untuk itu dipakai type PCQ (Per Connection Queue), yang bisa secara otomatis membagi trafik per client. Tentang jenis queue di mikrotik ini dapat dibaca pada manualnya di http://www.mikrotik.com/testdocs/ros/2.9/root/queue.php. Sebelumnya perlu dibuat aturan di bagian MANGLE. Seperti :

Code:


/ip firewall mangle add chain=forward src-address=192.168.0.0/27 action=mark-connection new-connection-mark=users-con


Code:


/ip firewall mangle add connection-mark=users-con action=mark-packet new-packet-mark=users chain=forward


Karena type PCQ belum ada, maka perlu ditambah, ada 2 type PCQ ini. Pertama diberi nama pcq-download, yang akan mengatur semua trafik melalui alamat tujuan/destination address. Trafik ini melewati interface Local. Sehingga semua traffik download/downstream yang datang dari jaringan 192.168.0.0/27 akan dibagi secara otomatis. Tipe PCQ kedua, dinamakan pcq-upload, untuk mengatur semua trafik upstream yang berasal dari alamat asal/source address. Trafik ini melewati interface public. Sehingga semua traffik upload/upstream yang berasal dari jaringan 192.168.0.0/27 akan dibagi secara otomatis. Perintah:

Code:


/queue type add name=pcq-download kind=pcq pcq-classifier=dst-address


Code:


/queue type add name=pcq-upload kind=pcq pcq-classifier=src-address


Setelah aturan untuk PCQ dan Mangle ditambahkan, sekarang untuk aturan pembagian trafiknya. Queue yang dipakai adalah Queue Tree, Yaitu:

Code:


/queue tree add parent=Local queue=pcq-download packet-mark=users


Code:


/queue tree add parent=Public queue=pcq-upload packet-mark=users


Perintah diatas mengasumsikan, kalau bandwidth yang diterima dari provider Internet berflukstuasi atau berubah-rubah. Jika kita yakin bahwa bandwidth yang diterima, misalkan dapat 256kbs downstream, dan 256kbps upstream, maka ada lagi aturannya, seperti : Untuk trafik downstreamnya :

Code:


/queue tree add name=Download parent=Local max-limit=256k


Code:


/queue tree add parent=Download queue=pcq-download packet-mark=users


Dan trafik upstreamnya :

Code:


/queue tree add name=Upload parent=Public max-limit=256k


Code:


/queue tree add parent=Upload queue=pcq-upload packet-mark=users

Sumber : http://dionipe.co.nr/

Entry filed under: Teknologi. Tags: .

PC Media Antivirus (PCMAV) 1.0 Final Release Mengenal 9 Tipe Kepribadian Manusia dengan Eneagram

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s

Trackback this post  |  Subscribe to the comments via RSS Feed


Kalender

April 2008
S S R K J S M
« Feb   Jun »
 123456
78910111213
14151617181920
21222324252627
282930  

Pos-pos Terbaru

A soup for Our Soul

My Chat’s


%d blogger menyukai ini: